Author [ES] [CA] [PL] [PT] [IT] [DE] [FR] [NL] [DK] [NO] [GR] [TR] Topic: Gen2 ownership dilemma  (Read 553 times)

0 Members and 1 Guest are viewing this topic.

Offline jaiyenyen

  • Explorer Pro
  • ***
  • Posts: 169
  • Bike: 2017 XCA
  • City / Town: courtenay bc
  • Country: canada
Re: Gen2 ownership dilemma
« Reply #10 on: September 09, 2019, 01:12:36 AM »
*Originally Posted by peejay1977 [+]
Hi all, I realise the ultimate answer to this is "Paul, it's your bike and your money, do what you feel is right". But I'm curious to get peoples thoughts.

So, I have a 2016 Explorer XR, which I've owned since June 2016. It was a pre release bike (I believe) as it's on a 65 plate and the first owner was the Triumph factory in Hinckley.

Since owning it I've put just short of 13,000 miles on it, including 3 trips to France. It's my first adventure bike and I've genuinely loved owning it. However, since owning it, I've had some "quality issues" which have always been dealt with properly by the dealer, but have me in the aforementioned dilemma.

So far, the bikes had a complete rear shock replaced under warranty, both front discs and pads plus all the captive frame engine bolts. It's also recently had a complete gearbox rebuild at a cost of just of just over £1000. I also recently had to replace the gear position sensor due to it repeatedly telling me that the TCS had been disabled and refusing to acknowledge which gear it's in.

I recently got back from the Pyrenees with my wife and I'm a little deflated with the bike in some ways, which are listed:

1. Engine heat, it's manageable but even at 23degress C I have to stand up and air out my groin as it ends up literally dripping with sweat, this is all while moving at speed let alone stationary.
2. The discs have warped, again, and is no longer under warranty. It could be the front wheel, god only knows how much that is.
3. The TCS issue has reared its head again and may be some sort of wiring/ECU issue with it thinking there's a voltage drop. (there's nothing after market drawing power).
4. Gearbox has started getting stuck in between gears again nearly causing me to lose control. Only happened twice since the rebuild but enough to scare the crap out of me. Combined with this while I was away I had about 20 instances of going from 1st to 2nd and getting neutral instead. While I accept this could be me, it's happened more in one trip than I have had on every bike I've ever owned, combined.
5. Rear tyre wear, covered in a separate thread. This seems to be due to the Pilot Road 5's than the bike itself.
6. Clutch biting point is getting tiring, even with my long fingers it's a struggle to operate as there's almost no movement between it biting and the lever being fully out. Something Triumph say they can't fix as its not a problem and is also present on the Gen3 (I've ridden one).

All in all I'm just a little disappointed. Might just be the biking blues but in 15 years of riding bikes, the Explorer is by far the best all rounder, but it's also the bike thats given me the most aggro and had the most quirks.

I guess you could say theres little point to me posting this, but spewing my guts about it at least felt good. As you were people lol
I have a 2017 XCA, bought new in 2017. No issues at all, not even excess engine heat. I think they are great bikes and you may have just got a bad one.

 


Recent Topics