Author [ES] [CA] [PL] [PT] [IT] [DE] [FR] [NL] [DK] [NO] [GR] [TR] Topic: 2013 Explorer exploded transmission  (Read 2150 times)

0 Members and 4 Guests are viewing this topic.

Offline 2sos

  • Explorer Member
  • **
  • Topic Author
  • Posts: 18
  • Bike: 2013 Triump Explorer
  • City / Town: Flowery Branch
  • Country: United States
Re: 2013 Explorer exploded transmission
« Reply #30 on: February 14, 2020, 01:53:13 AM »
One more

Offline XCaTel

  • Explorer Master
  • ****
  • Posts: 1072
  • Bike: 2018 T12 & 1995 D12
  • City / Town: County Kildare
  • Country: Ireland
Re: 2013 Explorer exploded transmission
« Reply #31 on: February 14, 2020, 07:34:41 AM »
Great investment. Hats off to your perseverance and thanks for sharing the progress.

Offline Icy

  • Explorer Master
  • ****
  • Posts: 2272
  • Stationary Traveler
  • Bike: 2018 TEX XCx
  • City / Town: Bronxville
  • Country: USA
Re: 2013 Explorer exploded transmission
« Reply #32 on: February 14, 2020, 01:11:58 PM »
The return of value is un-f'ing believable. Truly. And knowing that you can fix this thing no matter what - that's just priceless. Glad to have you around man. Kudos  :821: :028: :047:
"It's easy to learn how to speak, it takes a lot more to learn how to actually say something." ~Icy
http://instagram.com/soksa.icy/
http://www.flickr.com/photos/soksa/
https://www.youtube.com/user/SokSa/videos
http://www.swordclassri.com/

Offline CaptainTrips

  • Explorer God
  • *****
  • Posts: 4639
  • Bike: '13 Explorer
  • City / Town: Vancouver(ish)
  • Country: CA
Re: 2013 Explorer exploded transmission
« Reply #33 on: February 14, 2020, 06:50:01 PM »
My '13 TEX is almost identical, down to the Givi screen. BTW, run the coolant level in the overflow bottle at the low mark. Any more and it can overflow if you got stuck in stop and crawl traffic on a hot day.
"The test of the machine is the satisfaction it gives you. There isn't any other test."   --   Robert M. Pirsig

Offline 2sos

  • Explorer Member
  • **
  • Topic Author
  • Posts: 18
  • Bike: 2013 Triump Explorer
  • City / Town: Flowery Branch
  • Country: United States
Re: 2013 Explorer exploded transmission
« Reply #34 on: February 14, 2020, 06:53:29 PM »
*Originally Posted by CaptainTrips [+]
My '13 TEX is almost identical, down to the Givi screen. BTW, run the coolant level in the overflow bottle at the low mark. Any more and it can overflow if you got stuck in stop and crawl traffic on a hot day.

Nice. Good tip on the coolant level. I have it on the higher mark right now. I'll look at taking some out.

Offline 2sos

  • Explorer Member
  • **
  • Topic Author
  • Posts: 18
  • Bike: 2013 Triump Explorer
  • City / Town: Flowery Branch
  • Country: United States
Re: 2013 Explorer exploded transmission
« Reply #35 on: February 15, 2020, 03:38:50 PM »
All cleaned up and ready to go with the new turn signals. Now I just need to clear the maintenance notice.


















Online glenn389

  • Explorer Member
  • **
  • Posts: 48
  • Bike: Tiger 1200 XCA
  • City / Town: Rawdon
  • Country: UK
Re: 2013 Explorer exploded transmission
« Reply #36 on: February 15, 2020, 07:50:17 PM »
I have followed this thread with interest. A great result and hats off to you.  :037:

Offline jannerman

  • Explorer Pro
  • ***
  • Posts: 103
  • Bike: Tiger 1200 XRT
  • City / Town: Plymouth
  • Country: UK
Re: 2013 Explorer exploded transmission
« Reply #37 on: February 15, 2020, 11:06:27 PM »
@2sos : that's a damn fine liking motorcycle, I wish you a great many trouble free years/miles on you bike now it's sorted, good lick mate  :001:

 


Recent Topics